schovat načítání

Přecházím na jQuery 3

5.7.2016

Přecházím na jQuery 3

Nedávno vyšla nová verze knihovny jQuery a to verze 3, doposud jsem ve svých projektech standardně používal starší verzi 1.x, jelikož verze 2.x nepodporovala starší prohlížeče (například IE8). Verze 3 nabízí řadu zajímavých věcí a vylepšení, tedy v dalších projektech budu používat tuto nejnovější verzi, která podporuje prohlížeče IE9 a novější.

Jelikož obyčejně používám Bootstrap a ten zatím jQuery v3 nepodporuje, tak v tomto případě se vracím k 1.x, nicméně update Bootstrapu již určitě bude brzy.

Z mého pohledu je rozumné archaické prohlížeče jako IE8 vypustit, nicméně pokud by bylo třeba mohu zajistit správnou funkčnost i v těchto starých prohlížečích, samozřejmě při takovém požadavku je třeba počítat s odpovídajícím cenovým navýšením.